Back to overview
Resolved
Service degradation due to database load
Jul 1, 2026 at 9:12pm UTC
Affected services
app.meticulous.ai#test-run-execution
app.meticulous.ai#test-run-triggering
Resolved
Jul 1, 2026 at 11:04pm UTC
This incident is now resolved. If your run failed or is stuck in pending, please kick off a new one by pushing a new commit to your PR (you can add an empty one with git commit --allow-empty -m "Retry Meticulous" && git push). We apologise for the disruption and will be doing a full root cause analysis to ensure this incident isn't repeated.
Affected services
Created
Jul 1, 2026 at 9:12pm UTC
We are seeing delays and occasional failures executing test runs due to high database load.
Affected services