Back to overview
Resolved
Service degradation due to database load
Jun 18, 2026 at 8:10pm UTC
Affected services
app.meticulous.ai#test-run-execution
app.meticulous.ai#test-run-triggering
Resolved
Jun 19, 2026 at 12:13am UTC
Resolved.
Affected services
Created
Jun 18, 2026 at 8:10pm UTC
From 18:45 UTC on 18th June 2026, our database experienced connection saturation, causing a period of elevated error rates on API endpoints related to replay creation, session ingestion, and test-run polling.
Affected services