Back to overview
Degraded
Delay in test run execution
May 12, 2026 at 9:49pm UTC
Affected services
app.meticulous.ai#test-run-execution
Resolved
May 12, 2026 at 11:10pm UTC
All pending test runs have been executed.
Affected services
Created
May 12, 2026 at 9:49pm UTC
We're investigating a delay in test run execution created between 20:30 UTC and 21:30 UTC.
Affected services