Back to overview
Downtime
Service degradation due to database load
May 6, 2026 at 4:50pm UTC
Affected services
app.meticulous.ai
Resolved
May 6, 2026 at 5:25pm UTC
Database recovered.
Affected services
Created
May 6, 2026 at 4:50pm UTC
Between 16:30 and 16:50 UTC on 2026-05-06, our primary webapp database experienced connection saturation, causing a period of elevated error rates on API endpoints related to replay creation, session ingestion, and test-run polling.
Affected services