Back to overview
Degraded

Service degradation due to GitHub outage

Apr 27, 2026 at 5:30pm UTC
Affected services
app.meticulous.ai#test-run-execution
app.meticulous.ai#test-run-triggering
app.meticulous.ai#pr-approval-workflow

Resolved
Apr 27, 2026 at 9:40pm UTC

The GitHub outage has been resolved and performance should be back to normal now.

Updated
Apr 27, 2026 at 7:09pm UTC

Meticulous test runs are being impacted by an ongoing GitHub outage, see https://www.githubstatus.com/.

As a result, you may see Meticulous CI checks failing or failing to run on your pull requests. This is not an issue with your code or with Meticulous itself — it's a knock-on effect of GitHub's incident.

What to do once GitHub's incident is resolved:

Either re-run the CI workflow from the GitHub UI, or push an empty commit to your branch:

git commit --allow-empty -m "Retry Meticulous" && git push

Either will trigger Meticulous to run again as normal.

Created
Apr 27, 2026 at 5:30pm UTC

Service degradation due to GitHub outage. Some customers on GitHub might experience errors triggering test runs and approving diffs.