Back to overview
Degraded

Service degradation due to GitHub outage

Feb 23, 2026 at 9:21pm UTC
Affected services
app.meticulous.ai#test-run-execution
app.meticulous.ai#test-run-triggering
app.meticulous.ai#pr-approval-workflow

Resolved
Feb 23, 2026 at 10:27pm UTC

The GitHub outage has been resolved and performance should be back to normal now.

Created
Feb 23, 2026 at 9:21pm UTC

Service degradation due to GitHub outage