Back to overview
Degraded

Test Run Creation Currently Unavailable

Sep 19 at 06:09pm BST
Affected services
app.meticulous.ai#test-run-triggering

Resolved
Sep 19 at 07:58pm BST

This is now resolved

Created
Sep 19 at 06:09pm BST

We are currently experiencing issues that prevent new test runs from being created. Existing test runs will continue to process normally, and all other Meticulous services remain operational.

Our engineering team is actively investigating and working to restore test run creation capabilities. We will provide updates as soon as more information becomes available.