Back to overview
Degraded

Failing backend requests

Jan 15, 2025 at 4:56pm UTC
Affected services
app.meticulous.ai

Resolved
Jan 15, 2025 at 5:11pm UTC

We have identified the cause of the issue which is excessive load and scaled up our backend accordingly.

Created
Jan 15, 2025 at 4:56pm UTC

A number of requests to our backend are failing causing degraded service.