Back to overview
Downtime

Meticulous down for scheduled annual maintenance

Dec 21 at 11:09am GMT
Affected services
app.meticulous.ai
app.meticulous.ai#test-run-execution
app.meticulous.ai#test-run-triggering
app.meticulous.ai#pr-approval-workflow

Resolved
Dec 21 at 11:26am GMT

Stage 2 of annual scheduled maintenance completed successfully. Meticulous is back up.

Updated
Dec 21 at 11:23am GMT

Meticulous is down for stage 2 of the annual scheduled maintenance. Meticulous will be back up in around 10 minutes. Please contact Meticulous support if you have any questions or concerns.

Updated
Dec 21 at 11:14am GMT

Meticulous is back up, after completing the first stage of scheduled maintenance. We will take Meticulous back down shortly for the second stage of the maintenance.

Created
Dec 21 at 11:09am GMT

Meticulous will be back up in around 30 minutes. Please contact Meticulous support if you have any questions or concerns.