Back to overview
Degraded
Re-approving pull requests broken for a small proportion of pull requests that match all four of the conditions in the description
Oct 03 at 05:00pm BST
Affected services
app.meticulous.ai#pr-approval-workflow
Resolved
Oct 04 at 01:00am BST
Resolved issue which meant a small proportion of pull requests could not be re-approved once already approved. To be affected the pull requests had to match all four of the below conditions:
- PR created before 1am GMT+1 4th October
- PR approved
- Another commit pushed after 5pm GMT+1 3rd October but before 1am GMT+1 4th October and after the initial approval
- That additional commit had to trigger a test run which has diffs
Any pull requests which were affected can now be approved.
Affected services
Created
Oct 03 at 05:00pm BST
A BE regression meant that from it was not possible to reapprove a small subset of pull requests which were already approved but which had a new commit pushed that invalidated their original approval. To be affected the pull request had to fulfil all four of the below conditions:
- PR created before 1am GMT+1 4th October
- PR approved
- Another commit pushed after 5pm GMT+1 3rd October but before 1am GMT+1 4th October and after the initial approval
- That additional commit had to trigger a test run which has diffs
Affected services